RioLab

  • Aumenta dimensione caratteri
  • Dimensione caratteri predefinita
  • Diminuisci dimensione caratteri
Home Articoli Excel Calcolo dei giorni di un mese e dell'Anno bisestile

Calcolo dei giorni di un mese e dell'Anno bisestile

E-mail Stampa PDF
a cura di Paolo Ardizzoni

calcolare quanti giorni ci sono in un mese.

Due i modi:

1) calcolando la differenza in giorni fra il primo del mese in esame e quello successivo.

Supponiamo di immettere in A1 l'anno e in B1 il numero del mese, per es. rispettivamente 2012 e 10,

una soluzione:

=DATA(A1;B1+1;1)-DATA(A1;B1;1)

calcola cioè la differenza in giorni fra il primo del mese successivo e il primo di quello in oggetto.

2) una seconda soluzione che sfrutta le specifiche della funzione DATA():

=GIORNO(DATA(A1;B1+1;0)) 

con DATA() calcola l'ultimo giorno del mese in oggetto e ne restituisce il numero con la funzione GIORNO(). Infatti lo 0, terzo argomento della funzione DATA(), non fa altro che rimandare al giorno precedente il primo giorno del mese successivo (B1+1).


Anno bisestile

Il calcolo dell'anno bisestile deriva di conseguenza dal calcolo precedente in quanto si tratta di determinare se il mese di febbraio ha 28 o 29 giorni.

Ciò premesso useremo la seguente:

=GIORNO(DATA(A1;3;0)) dove in A1 c'è l'anno; se verrà restituito 29 l'anno sarà bisestile, in caso contrario no.

La risposta potremmo chiederla ad Excel:

=SE(GIORNO(DATA(A1;3;0))=29;"SI";"NO")


Per tutte le versioni di Excel.

Ultimo aggiornamento Domenica 11 Gennaio 2015 10:21  

Pubblicità

Link consigliati: