RioLab

  • Aumenta dimensione caratteri
  • Dimensione caratteri predefinita
  • Diminuisci dimensione caratteri
Home Articoli MS Excel Cerca valori con più criteri

Cerca valori con più criteri

E-mail Stampa PDF

 Domanda

Nella tabella seguente vorrei individuare il più alto dei valori in colonna [G] ("Ore"), in corrispondenza dei valori "1" in colonna [A] e "c" in colonna [E].

Nell'esempio vorrei ottenere 12.05.17."

 

 
A
B
C
D
E
F
G
1
1
04/12/2007
Roberto
11.58.46
a
i
11.58.49
2
2
04/12/2007
Roberto
11.33.16
b
i
12.00.12
3
1
04/12/2007
Roberto
11.33.16
c
i
12.03.47
4
1
04/12/2007
Roberto
11.33.16
c
i
12.05.17

 

Risposta ( di Maurizio Borrelli)

 

Innanzitutto inserisci i valori da cercare nelle seguenti celle, così puoi variarli per effettuare altre ricerche:

[J2]:       1

[K2]:      c

in [H2] applica una delle seguenti formule:

=MAX((A1:A4=J2)*(E1:E4=K2)*(G1:G4)) da inserire come matriciale con [CTRL]+[MAIUSC]+[INVIO]

oppure:

=MATR.SOMMA.PRODOTTO(MAX((A1:A4=J2)*(E1:E4=K2)*(G1:G4)))

oppure:

=INDICE(MAX((A1:A4=J2)*(E1:E4=K2)*(G1:G4));1)

Se in colonna [G] vi sono Ore devi assegnare alla cella che contiene la formula il formato "Ora".

 

N.B. nel caso in cui i valori da cercare non fossero ore ma numeri sarebbe necessario che fossero positivi.

 


 

Sistema operativo: Win32

Applicazioni: Excel 2000, Excel 2002/XP, Excel 2003, Excel 2007
 

 

Pubblicità

Link consigliati: