RioLab

  • Aumenta dimensione caratteri
  • Dimensione caratteri predefinita
  • Diminuisci dimensione caratteri
Home Articoli MS Excel Somma Prodotto Condizionata

Somma Prodotto Condizionata

E-mail Stampa PDF

Domanda

 

Vorrei ottenere in una cella la somma del prodotto dei valori in due colonne condizionata dal valore in una terza.
In un foglio ho le seguenti colonne: Nome, Organizzazione, Tariffa, Ore.
Vorrei ottenere in un cella il risultato sommatoria del prodotto Tariffa x Ore di tutti gli elementi che appartengono ad una data Organizzazione.

Risposta ( di Maurzio Borrelli)

 

Supponendo che la riga delle intestazioni sia la prima, a partire dalla prima colonna, e che tu abbia 20 righe di dati, posto che il nome dell'Organizzazione di cui ottenere il totale sia nella cella "G1", allora dovrebbe fare al caso tuo la formula:

 

=MATR.SOMMA.PRODOTTO(--(B2:B21=G1);C2:C21;D2:D21)

 

Attenzione: nella formula è importante non trascurare di inserire le due lineette prima dell'uguaglianza. Questa infatti, anziché restituire VERO o FALSO (in relazione alla verifica o meno del criterio), si avvalora rispettivamente con 0 o 1.


 

Sistema operativo: WIN32

Applicazioni: Excel 97, Excel 2000, Excel 2002/XP, Excel 2003, Excel 2007

 

 

 

Pubblicità

Link consigliati: