RioLab

  • Aumenta dimensione caratteri
  • Dimensione caratteri predefinita
  • Diminuisci dimensione caratteri
Home Articoli MS Excel Trasforma Matrice in Vettore

Trasforma Matrice in Vettore

E-mail Stampa PDF

Domanda


Dispongo della seguente matrice di valori:
 
 
A
B
C
D

1

 
2
3
4

2

1
a
b
c

3

2
e
f
g

4

5

h

i

j

5

.... .... .... ....
Vorrei "trasformare" la matrice in un vettore elencando in colonna i dati della matrice come segue:
 
 
A
B
C
D

1

1
2
a
 

2

1
3
b
 

3

1
4
c
 

4

2

2

e

 

5

2

3

f

 

6

2

4

g

 

7

5

2

h

 

8

5

3

i

 

9

5

4

j

 

Risposta (di Ivano Chiappa)


inserisci le seguenti formule:
in [F1] =SCARTO($A$1;INT((RIF.RIGA(A1)-1)/COLONNE($B$2:$D$4))+1;0)
in [G1] =SCARTO($A$1;0;RESTO((RIF.RIGA(A1)-1);COLONNE($B$2:$D$4))+1)
in [H1] =INDICE($B$2:$D$4;CONFRONTA(F1;$A$2:$A$4;0);CONFRONTA(G1;$B$1:$D$1;0))
oppure
=SCARTO($A$1;INT((RIF.RIGA(A1)-1)/COLONNE($B$2:$D$4))+1;RESTO((RIF.RIGA(A1)-1);COLONNE($B$2:$D$4))+1)

e trascina in basso quanto basta.


Sistema operativo: WIN32

Applicazioni: Excel 97, Excel 2000, Excel 2002/XP, Excel 2003, Excel 2007

 

 

 


Allegati:
FileDescrizioneDimensione del File
Scarica questo file (TrasformaMatriceVettore.xls)Trasforma matrice in vettore 43 Kb
Ultimo aggiornamento Domenica 05 Luglio 2009 21:00  

Pubblicità

Link consigliati: