RioLab

  • Aumenta dimensione caratteri
  • Dimensione caratteri predefinita
  • Diminuisci dimensione caratteri
Home Articoli Excel Calcoli su dati filtrati

Calcoli su dati filtrati

E-mail Stampa PDF

Domanda

Ho una tabella alla quale applico un filtro.
La funzione SUBTOTALE(9; ....) consente di ottenere il totale dei valori di una colonna tenendo conto dei valori filtrati.
Analogamente, come posso fare il conteggio, tipo CONTA.SE, del numero delle celle che soddisfano un certo criterio anche dopo l'applicazione del filtro?


Per esempio, con questi valori: 

Se in [C1] metto il dato da cercare nella colonna [B], in questo caso "giallo", il risultato di CONTA.SE(B2:B10;C1) sulla colonna [B] è pari a 3.

Se adesso filtro la colonna [A] con "Pip", ottengo: 

Che formula devo applicare per ottenere il risultato filtrato?

 Risposta (di Giovanna Arcadu)

Come hai già verificato, non è possibile applicare la funzione CONTA.SE ad un intervallo filtrato poiché questa effettua comunque il calcolo di tutte le celle, comprese quelle non visibili.
Per tenere conto delle sole celle visibili occorre applicare la seguente formula:
 
=MATR.SOMMA.PRODOTTO(SUBTOTALE(3;SCARTO(A1:A10;RIF.RIGA(A1:A10)-MIN(RIF.RIGA(A1:A10));;1));--(B1:B10=C1))
 
che restituisce il seguente risultato:

 

Sistema operativo: WIN32
Applicazioni: Excel 97, Excel 2000, Excel 2002/XP, Excel 2003, Excel 2007

 

Ultimo aggiornamento Lunedì 03 Agosto 2009 12:55  

Pubblicità

Link consigliati: